KB269: How to reconnect your Moxie Player or Studio to your Data Server

Summary

A Moxie digital signage network consists of one or more Players, Studios and a Data Server. To facilitate network communication, a Moxie Data Proxy can also be part of a Moxie network. Whether these components are installed on the same or different computers, they all communicate using TCP/IP. Communication between components is bidirectional with the Data Server acting as the central information hub.

When any Moxie components are installed on a computer, the Moxie Agent is also installed. One of the Agent's responsibilities is to maintain the connection information to the Data Server or Data Proxy.

The Moxie Agent also has the additional responsibility of starting the Connection Wizard. The Connection Wizard is a series of dialogs that are used to establish and test a component's connection information to the Data Server or Data Proxy.

Occasionally, user actions and network or configuration changes prevent the Studios and Players from connecting with the Data Server or Data Proxy. These changes do not restart the Moxie Network Connection Wizard automatically on the Studio or Player computers because their Agent may not have been notified of the change. Additional steps are required to start the Connection Wizard.

Symptom

Your Moxie Player or Studio is not connected to your Data Server or Data Proxy and the Connection Wizard does not appear when you start these components.

Cause

If the Player or Studio has cached connection data that no longer exists at the Data Server then the Data Server will not recognize the connection. External behavior may appear normal but communication between Moxie components is affected by this connection data discrepancy.

There are several scenarios that reflect this connection data discrepancy and do not start the Connection Wizard:

  • Your Player or Studio is connected to a Data Server or Data Proxy and you want to connect to a different Data Server or Data Proxy.

    The Connection Wizard does not appear at the Player or Studio when they start and as a result, you cannot connect to a different Data Server or Data Proxy.
  • Your Player and Studio were connected to a Data Server or Data Proxy which has been deleted, along with its content and connection data, and then reinstalled.

    The Player and Studio have their connection and content data from the previous Data Server or Data Proxy installation. The new Data Server or Data Proxy no longer has connection information or content so the Player or Studio's cached data is no longer valid.

    The Connection Wizard does not appear at the Player or Studio when they start and as a result, you cannot connect to the newly installed Data Server or Data Proxy.
  • A Player has been deleted from the Data Server using the Studio's Player Manager module. This deletion only affects the internal player list in the Data Server and does not delete the remote Player component's cached data on the Player computer. The Player component retains the connection data but the Data Server no longer recognizes the Player. The Player's content display also appears as expected because it is displaying its previously cached content but the Player is not listed in the Player Manager module so content changes cannot be transmitted to the Player.

    The Connection Wizard does not appear at the Player when it starts and as a result, you cannot reconnect to a Data Server or Data Proxy.

Solution

Note: The following procedure should only be performed on computers that only have Moxie Studio or Player installed on them and not on computers that also have Moxie Data Server or Proxy installed.

In order to automatically start the Connection Wizard on a Studio or Player computer, all of the existing connection data that resides on the computer must be deleted. The next time you start the computer, which no longer has this data, Moxie automatically starts the Connection Wizard so you can re-establish your connection to your Data Server.

To delete your connection data:

  1. Open Control Panel  >  Administrative Tools  >  Services
  2. From the Services Name list, select Omnivex Moxie Agent.
  3. Click Stop the service and accept confirmation of any additional, dependent Moxie services that must also be stopped.
  4. If your Player or Studio computer is running Windows Vista, 7 or Server 2008,use Windows Explorer and browse to:
    1. on a 32-bit system: <systemdrive> ProgramData > Omnivex > Moxie > Drive C > Program Files > Omnivex > Moxie
    2. on a 64-bit system: <systemdrive> ProgramData > Omnivex > Moxie > Drive C > Program Files (x86) > Omnivex > Moxie
  5. Or if your Player or Studio computer is running Windows XP or Server 2003, use Windows Explorer and browse to:
    1. on a 32-bit system: <systemdrive> Documents and Settings > All Users > Application Data > Omnivex > Moxie > Drive C > Program Files > Omnivex > Moxie
    2. on a 64-bit system: <systemdrive> Documents and Settings > All Users > Application Data > Omnivex > Moxie > Drive C > Program Files (x86) > Omnivex > Moxie
  6. Delete the Agent, Studio and/or Player directories (and all sub-directories).
  7. Restart Omnivex Moxie Agent and any additional, dependent Moxie services.
  8. Restart Moxie Studio and/or Player. The Connection Wizard appears.
  9. Configure the Connection Wizard to establish the connection of your Studio and/or Player to your Data Server or Data Proxy.

Was this information helpful?

Was this information helpful?