KB340: Moxie Players display "No licensed Player connections remain at the Moxie Data Server."

Symptom

Moxie Players display a "No licensed Player connections remain at the Moxie Data Server. Check with your Moxie Administrators to ensure that connection are available" message. Either:

  1. Some Moxie Players display this message OR
  2. All Moxie Players display this message

Cause

Depending on your symptom (a or b), either:

Creating a manual Moxie failover environment

Summary

When working on a production network, a Data Server failover is a best-practice. This minimizes the possibility of data loss in the event of a catastrophic hardware failure. Automated failover support is available in Moxie 7.05.

Scope

This document is intended as a reference for creating and configuring a Moxie failover environment. It covers new Moxie installations as well as Moxie upgrades.

KB322: How to: Connect a Moxie Player to a different new or existing server

Summary

A Moxie digital signage network consists of a collection of components that communicate with each other via TCP/IP. When a Moxie Player is installed on a display's computer, it also installs a supporting communication service; the Moxie Agent. By design, Moxie Agent is always running so it can respond quickly to any new instructions it receives from the server including remote updates of Moxie Player.

KB140: When you launch your Moxie Studio, it says Loading... but your Modules never load

Symptom

When you launch your Moxie Studio, it says Loading... but your Modules never load or appear in your Modules list.

Cause

Your Moxie Studio is unable to connect to your Data Server, either because there is no longer a Data Server at the specified location or the specified location does not exist.

Solution

Connect to a different Data Server or change your Data Server connection configuration.

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