KB19: Your data on the DataPipe Server disappears when you close your DataPipe Client

Symptom

Any data that you have entered from your DataPipe Client disappears from your DataPipe Server when you close your Client application.

Cause

Either your DataPipe Server is running in the non-persistent data mode or your DataPipe Client is configured to clear data on exit. When persistent data mode is disabled, only data from clients that are currently connected to your Server are shared across your DataPipe network.

Solution

Configure your DataPipe Server so that it is running in the persistent data mode, so that it retains data from disconnected Clients.

To set your DataPipe Server to run in persistent data mode:

  1. From your DataPipe Server, click Tools > Options. The Options dialog box appears.

  2. Select the Save data to disk automatically check box.
  3. In Every set the number of seconds between saves.
  4. Click OK.

You have successfully configured your DataPipe Server to run in persistent data mode. Your DataPipe Server now saves all of the data it receives at the interval you set. It also saves data when the program exits. Next you need to configure your DataPipe Client to leave the data it has contributed to your Server when you close it.

To set your DataPipe Client to leave your data behind:

  1. From your DataPipe Client, click Tools > Options. The Options dialog box appears.
  2. Click the Automation tab.

  3. Clear the Clear data values updated by this instance check box.
  4. Click OK.

You have successfully configured your DataPipe Client to leave its data behind when you exit.

Applies to:

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